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Introduction
You can use Contract Administration to enter, set up, and maintain your quote and 
contract documents. If Contract Administration is integrated with Service Call 
Management, the actual contract costs are updated from service calls and contract 
terms update service calls. If Contract Administration is integrated with Sales Order 
Processing, contract billing results in the creation of customer invoices. Contract 
Administration also will send transactions to General Ledger for revenue 
recognition purposes.

The introduction is divided into the following topics:

• What’s in this documentation
• Symbols and conventions
• Resources available from the Help menu
• Send us your documentation comments

What’s in this documentation

This manual is designed to give you an understanding of how to use the features of 
Contract Administration, and how it integrates with the Microsoft Dynamics™ GP 
system.

To make best use of Contract Administration, you should be familiar with 
systemwide features described in the System User’s Guide, the System Setup 
Guide, and the System Administrator’s Guide.

Some features described in the documentation are optional and can be purchased 
through your Microsoft Dynamics GP partner.

To view information about the release of Microsoft Dynamics GP that you’re using 
and which modules or features you are registered to use, choose Help > About 
Microsoft Dynamics GP.

The manual is divided into the following parts:

• Part 1, Contract Administration setup, introduces Contract Administration and 
explains the setup of it.

• Part 2, Transaction activity, explains how to enter quotes and contracts. It also 
explains how to transfer contract documents.

• Part 3, Inquiries and reports, explains how to use inquiries and reports to 
analyze your contract information.

Symbols and conventions

For definitions of unfamiliar terms, see the glossary in the manual or refer to the 
glossary in Help.

Symbol Description

The light bulb symbol indicates helpful tips, shortcuts, and suggestions.
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I N T R O D U C T I O N

This manual uses the following conventions to refer to sections, navigation, and 
other information.

Resources available from the Help menu

The Microsoft Dynamics GP Help menu gives you access to user assistance 
resources on your computer, as well as on the Web.

Contents
Opens the Help file for the active Microsoft Dynamics GP component, and displays 
the main “contents” topic. To browse a more detailed table of contents, click the 
Contents tab above the Help navigation pane. Items in the contents topic and tab 
are arranged by module. If the contents for the active component includes an 
“Additional Help files” topic, click the links to view separate Help files that 
describe additional components.

To find information in Help by using the index or full-text search, click the 
appropriate tab above the navigation pane, and type the keyword to find.

To save the link to a topic in the Help, select a topic and then select the Favorites 
tab. Click Add.

Index
Opens the Help file for the active Microsoft Dynamics GP component, with the 
Index tab active. To find information about a window that’s not currently 
displayed, type the name of the window, and click Display.

About this window
Displays overview information about the current window. To view related topics 
and descriptions of the fields, buttons, and menus for the window, choose the 
appropriate link in the topic. You also can press F1 to display Help about the current 
window.

Lookup
Opens a lookup window, if a window that you are viewing has a lookup window. 
For example, if the Checkbook Maintenance window is open, you can choose this 
item to open the Checkbooks lookup window.

Show Required Fields
Highlights fields that are required to have entries. Required fields must contain 
information before you can save the record and close the window. To change the 

The warning symbol indicates situations you should be especially aware 
of when completing tasks.

Convention Description

Creating a batch Italicized type indicates the name of a section or procedure.

File > Print The(>) symbol indicates a sequence of actions, such as selecting items 
from a menu or a toolbar or pressing buttons in a window. This example 
directs you to go to the File menu and select Print.

TAB or ENTER Small capital letters indicate a key or a key sequence.

Symbol Description
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way required fields are highlighted, choose Tools > Setup > User Preferences > 
Display, and specify a different color and type style.

Printable Manuals
Displays a list of manuals in Adobe Acrobat .pdf format, which you can print or 
view.

Orientation Training
Accesses online tutorials that show you how to complete basic procedures within 
Microsoft Dynamics GP. Additional tutorials are available through the 
CustomerSource Web site.

What’s New
Provides information about enhancements that were added to Microsoft Dynamics 
GP since the last major release.

Microsoft Dynamics GP Online
Opens a Web page that provides links to a variety of Web-based user assistance 
resources. Access to some items requires registration for a paid support plan.

Current implementation and upgrade information The most recent 
revisions of upgrade and implementation documentation, plus documentation 
for service packs and payroll tax updates.

User documentation and resources The most recent user guides, how-
to articles, and white papers for users.

Developer documentation and resources The most recent 
documentation and updated information for developers.

Product support information Information about the Microsoft Dynamics 
GP product support plans and options that are available, along with 
information about peer support and self-support resources.

Services information Information about Microsoft Dynamics GP support, 
training, and consulting services.

Microsoft Dynamics GP Community Access to newsgroups, where you 
can ask questions or share your expertise with other Microsoft Dynamics GP 
users.

CustomerSource home page A wide range of resources available to 
customers who are registered for a paid support plan. Includes access to 
Knowledge Base articles, software downloads, self-support, and much more.

U.S. Payroll Updates
Provides access to tax updates for state and federal tax withholding. When you 
select an option, the process to install the updates will begin immediately.

Check with your system administrator before installing tax updates. To be sure that tax 
updates are installed correctly, refer to documentation for specific tax updates on the 
CustomerSource Web site.
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I N T R O D U C T I O N

Customer Feedback Options
Provides information about how you can join the Customer Experience 
Improvement Program to improve the quality, reliability, and performance of 
Microsoft® software and services.

Send us your documentation comments

We welcome comments regarding the usefulness of the Microsoft Dynamics GP 
documentation. If you have specific suggestions or find any errors in this manual, 
send your comments by e-mail to the following address: bizdoc@microsoft.com.

To send comments about specific topics from within Help, click the Documentation 
Feedback link, which is located at the bottom of each Help topic.

Note: By offering any suggestions to Microsoft, you give Microsoft full permission to use 
them freely.

mailto:bizdoc@microsoft.com
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Part 1: Contract Administration 
setup
This part of the documentation contains procedures and information for setting up 
and customizing Contract Administration for your business. During the setup of 
Contract Administration, you’ll select options, set up and customize contract types, 
and specify default entries that are displayed when you enter transactions.

Setup procedures generally need to be completed only once, but you may refer to 
this part of the documentation at other times to modify or view existing entries. 

The following topics are discussed:

• Chapter 1, “Setup overview,” introduces Contract Administration document 
types and explains how to use the Setup Checklist.

• Chapter 2, “Setup in Contract Administration,” explains in detail how to set up 
each document and item within Contract Administration.
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Chapter 1: Setup overview
The setup procedures are organized in an order that ensures proper setup.

This information is divided into the following topics:

• Contract Administration workflow
• Contract Administration document types
• Before setting up Contract Administration
• Use the Setup Checklist

Contract Administration workflow

As a contract service provider, your customers seek agreements that allow them 
service for their equipment at their locations. They may approach you looking for 
answers about coverage options, prices, and types of equipment you can service for 
them. You can create a quote for the customers’ information. At a later time, you can 
transfer that quote to a contract. As they place service calls, you can provide service 
for their equipment, track that service, and send your customers invoices, all based 
on the terms of the contract. You can recognize the revenue you earn for the contract 
as time passes. Finally, when the contract ends, you can renew the contract as the 
customer desires.

This simple work flow is common to many contract service providers. It illustrates 
the basic movement of information and documents through Contract 
Administration. 

The following diagram outlines the stages of the contract life cycle, from entry 
through revenue recognition. Contract Administration helps you manage your 
contracts through this life cycle. When Contract Administration is integrated with 
the other modules of the Field Service Series (Service Call Management, Preventive 
Maintenance, Returns Management, and Depot Management), many new options 
and work flow paths become available.

You can create contracts from the following points of access. Both are covered in this 
documentation.

• In the Contract Entry/Update window
• In the Sales Contract Entry window
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Contract Administration document types

Use Contract Administration to create, print, and use contract documents. You can 
transfer contract documents from one type to another. You can set up the following 
types of documents within Contract Administration:

Template You can use a basic document header to begin contracts for many 
different customers. Templates usually don’t contain contract line information, 
because lines vary from contract to contract. These template contract headers 
minimize the time spent typing new quotes or contracts by using the default 
contract header information. You can specify a new customer ID, address ID, and 
start date during the contract transfer process.

Quote You can provide a document with an estimate of a contract’s potential 
price for customers during contract negotiations. You can modify quotes infinitely, 
by using the What If window or by making changes manually, to provide different 
pricing scenarios. Once a quote is agreed on, you can transfer it to a contract. At the 
end of a contract’s term, you can transfer the contract again to a quote for re-
negotiation and to history for long-term storage. 

Contract You can use a contract with other modules, such as Service Call 
Management, allowing the servicing of customers’ equipment under the terms of 
the contract agreement. A contract also can be billed and revenue can be recognized 
during the contract life cycle.

Before setting up Contract Administration

Before setting up Contract Administration, complete the setup procedures for Sales 
Order Processing, Receivables Management, Inventory Control, and General 
Ledger, including the following tasks:

• Create general ledger accounts for revenue, deferred revenue, and accounts 
receivable.

• Enter customer records, including default general ledger accounts.

• Enter inventory cards for items that are under contract, as well as for contract 
“billing” items.

• Create invoice and return document types in Sales Order Processing.

For more information, see the Receivables Management, Sales Order Processing, 
and Inventory Control documentation.

If you’re using Contract Administration with Multicurrency Management, be sure 
you’ve also set up currencies, exchange rate tables, and Multicurrency default 
entries. For more information, see the Multicurrency Management documentation.

Use the Setup Checklist

When setting up Contract Administration, either open each setup window and type 
information, or use the Setup Checklist window (Tools > Setup > Setup Checklist) 
as a guide. See the System Setup Guide (Help > Printable Manuals) for more 
information.
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Chapter 2: Setup in Contract Administration
Contract Administration setup involves setting up preferences such as data entry 
default entries, coverage options, and contract pricing.

When you set up Contract Administration, you can open each window and type 
information or you can follow the Setup Checklist, which you can use as your guide 
to the setup process. For more information, see Use the Setup Checklist on page 10.

This information is divided into the following topics:

• Set up contract price books
• Set up contract types
• Set up options and default entries
• Set up contract document security
• Set up contract options
• Set up item extensions
• Set up customer extensions
• Set up warranties
• Set up equipment maintenance cards

Set up contract price books

Because Inventory Control item pricing is designed for selling products, not for 
providing contract service pricing, Contract Administration contains separate 
pricing setup. Contract pricing is set up around a price book, which contains the 
details regarding standard pricing and the up-charges associated with different 
contract options.

Contract price books allow the entry of standard pricing based on up to four 
criteria: item number, item class, customer number, and customer class. These 
criteria can be combined in an almost unlimited mixture of pricing schedules.

Pricing information is stored within a price book using one or more criteria from the 
following choices: item class, item number, customer class, and customer number. 
You can select a variety of choices, and you can make the pricing as generic or 
specific as you want.

Detailed contract price information is typed within a price book, which is a 
grouping of various pricing sheets. The price sheets can be grouped based on 
whichever factors you define. Some typical examples include customer types, such 
as having a price book for corporate customers, another for residential customers, 
and a third for governmental accounts. Another approach is to specify price books 
by the year when they are used, so that as prices rise or fall, the price book 
accurately reflects those changes.

When contract pricing is selected on your contract lines, a valid price will be used 
based on a hierarchy of the four criteria you can choose when assigning contract 
pricing. That hierarchy is shown below in order so you can set up the correct pricing 
schedules for your business.

• Customer Number and Item Number
• Customer Number and Item Class
• Customer Class and Item Number
• Customer Class and Item Class
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• Customer Number
• Customer Class
• Item Number
• Item Class

The base cost is used when calculating the proactive profitability on your contracts 
and quotes, so you can better ensure contract profitability during the early contract 
negotiations. The base cost and the base price are adjusted automatically for any 
contracts that are longer or shorter than a calendar year.

You can assign the contract options that you’ve created already to various contract 
price book lines so that you can provide your customers with different contract 
options. While some customers might choose a basic contract service plan with 
office-hour coverage, others might opt for 24/7 support, multiple site coverage, or a 
premium support agreement that ensures more personalized services.

You do not need to assign every contract option to every contract price book line, 
only to those contract lines the option pertains to. For example, you might offer 24/
7 support for network servers but not for dot-matrix printers. In that case, you 
would assign the 24/7 option code to the network server’s price book line, but not 
to the dot-matrix printer’s price book line.

1. Open the Contract Pricing Maintenance window.
Cards > Contract Administration > Contract Pricing

2. Click Copy to create or modify new or existing price books.

3. Enter or select a price book.

4. Select the item and customer criteria for the contract price book line.

5. Enter the base price that is based on a calendar year. 

6. Enter the base cost for the contract price book line based on a calendar year. 

7. Enter or select a contract price line option ID.

8. Select whether to increase or decrease the percent in the Price/Percent field.



F I E L D  S E R V I C E  -  C O N T R A C T  A D M I N I S T R A T I O N 13

C H A P T E R  2    S E T U P  I N  C O N T R A C T  A D M I N I S T R A T I O N

9. If you chose a percentage increase or decrease in base price, type the actual 
percentage that the base price is affected by. 

10. If you selected price as the method, type the positive or negative currency value 
in the Price field on the second line of the contract option.

When typing a price for a contract option, you can type the value as either a positive 
(increase) or negative (decrease) value.

11. Enter a cost associated with providing the optional contract service on the 
second line of the contract line option. This cost is added to the base cost of the 
contract service to provide an accurate view of your proactive contract 
profitability.

12. Select the Cumulative check box on each contract line option to use the base 
price plus the price of any contract line options selected before it to create a 
contract price.

The cumulative option is used only for contract price options that are selected as a 
percent increase or a percent decrease.

For example, assume a third contract option for multiple site coverage with a 
percentage increase of 10 percent was added to the example provided earlier in 
this topic. If that third option was cumulative, the contract price would increase 
by $37.50 (($300 + 75) * 10%). However, if the third option was not cumulative, 
the contract price would increase by only $30 ($300 * 10%).

13. Click Save.

Set up contract types

You can set up and customize an unlimited number of contract types. When you 
create a new contract document, you’ll select the contract type to use from what 
you’ve set up here.

When contracts are billed, much of the information comes directly from the contract 
type assigned to the contract document. The item number that is assigned to the 
contract type is used on each line item in Sales Order Processing when the contract 
is billed. Because physical quantities are not sold through contract billing, this item 
should be set up in Inventory Control as a miscellaneous, flat fee, or services item 
type. If you bill in detail, the item number of the item that was shown on the 
contract is shown in the line item description of the Sales Order Processing Invoice.

For example, you can set up different contract types for your wholesale, retail, and 
governmental customers.

If you specify that the contract type is pre-billed, contracts using this contract type 
are billed at the beginning of the contract coverage period. If it is not pre-billed, the 
billing takes place after contract services have been rendered. 

If you bill in detail, each item on the contract will have one billing line item. If you 
bill in summary, a single billing line item will represent the entire contract.

Any field service calls generated in Service Call Management for an item on the 
contract will use the specified service type.
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By setting up a document ID and a batch ID, you can separate your contract billing 
invoices in Sales Order Processing from invoices that are generated for sales or 
service call billings. You also can use separate document IDs and batch IDs for the 
credits that are generated when you cancel a previously billed contract or contract 
line. 

You can track equipment usage and bill the customer for additional usage that 
exceeds a set amount. You can type the default meter overage information for the 
contract type, then add it to each contract and modify it as needed.

1. Open the Contract Type Maintenance window.
Cards > Contract Administration > Contract Types

2. Enter or select a contract type ID.

3. Select whether the contract type is prepaid and whether it is billed in detail. 

4. Enter or select a default service type for contracts that are created using the 
contract type. 

5. You can assign two general ledger account numbers that are used in the billing 
and revenue recognition processes. 

Accrual/Liability For contracts that recognize revenue separate from billing. 
The Accrual/Liability account shows the deferred revenue amounts when the 
contract is billed. 

Sales Account For contracts that are billed monthly, and shows the 
recognized portion of the deferred revenue each month when you run revenue 
recognition.

6. Enter or select a document ID for contract billing.

7. Enter or select a batch ID. 

8. Select the Account Discount option and type a discount-taken account, which 
shows any discount amounts used on contracts in the proper general ledger 
account.
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9. Select when the contract type is in force. Enter the days and the starting and 
ending times in a 24-hour format. 

10. Enter the contract response time in hours and minutes to show the amount of 
time that a service call response must be provided within.

11. Click Meters to create the default meter information.

Enter the base meter usage that is allowed under the contract type. For example, 
a contract type used to cover 12-month contracts for office copier machines 
might allow for use of 2,000 copies per month. In that case, you would type 
24,000 as the base meter usage for a 12-month contract.

Select the Exp. check box if the contract coverage for the metered equipment 
item expires once the base meter usage is reached. Any service calls taken from 
that point forward would be fully billable to the customer, as if no contract 
existed.

Enter up to four meter overages, which can be tracked and billed for each meter 
on a piece of equipment. A different charge can be placed on each overage layer. 

For example, assume that after the 24,000 base meter usage is reached, the next 
5,000 copies are allowed at a billing rate of $.01 per copy, then another layer for 
8,000 copies at $.03 per copy. You can show the usage by placing 5,000 in the 
Overage 1 field, with $.01 as the Overage 1 currency amount. Follow this with 
13,000 (5,000 + 8,000) as Overage 2 and $.03 as the currency amount.

You can show the meter information for up to 5 separate meters within the 
same piece of equipment. You can allow for tracking of items such as color laser 
printers, where two different meters can be used to track color copies or black 
and white copies.

Click OK to return to the Contract Type Maintenance window.

12. Click Save.

Set up options and default entries

You can set up default entries and other information that will affect the contract 
documents you create. You also can set up security options for contract documents.

To accelerate the transaction entry process, specify common entries that will appear 
automatically when you create contract documents.
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1. Open the Service Setup - Contracts window.
Tools > Setup > Project > Service Setup > Contract button

2. Select the default contract record type for new documents. 

3. Enter the ID for the default contract type once you’ve set up at least one 
contract type. For more information, see Set up contract types on page 13.

4. Enter or select the price book ID, document ID, batch ID, credit document ID, 
and credit batch ID you use most often.

5. Enter the next contract number to be used by each new contract document you 
create. The system automatically adds leading zeros to the number you type to 
create the full 10-character document number.

6. Set contract options.

Include Callbacks Indicates that you want to update applicable contracts 
for callback service calls.

Allow $0.00 SOP Lines Indicates that the system should allow users to 
process contract transactions through SOP even when there are lines that have 
no currency value for the selected customer record.

Auto Create Contract from SOP Indicates that the system will create a 
service contract automatically when the SOP invoice is posted.

Include Warranty Indicates that the service contract line extended price is 
prorated based on the number of days the warranty is active during the contract 
coverage period.

Non-invoiced Revenue Recognition Indicates that you want to recognize 
revenue against contracts that do not have invoices posted against them.

Create History Distribution Records Indicates that corresponding 
distribution history records will moved to history when the contract is moved 
to history.

7. Click Save.
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Set up contract document security

Because templates, quotes, contracts, and history documents all can be deleted in 
the Contract Entry/Update window, your business processes might require that 
users be prevented from removing these documents. You can prevent users from 
deleting certain documents, while still allowing them to access the window to create 
or update documents, by setting passwords.

If you set up a password, users are required to type the password before deleting 
the select document type. If an option is selected, but a password hasn’t been set up, 
anyone who has access to the window can delete the applicable document type.

For more information about setting up security, see the System Setup Guide (Help > 
Printable Manuals).

1. Open the Option Security - Contract Administration window.
Tools > Setup > Project > Service Setup > Contract > Options

2. Select the document type that you’re setting up document security privileges 
for.

3. To remove the right for users to delete a particular document type, clear the 
Allow check box.

4. To use passwords, type a password for each option. 

5. Click OK.

Set up contract options

Contract options provide an unlimited number of variations within the contract 
process. You can set up the various options that customers can choose from. For 
example, if you provide an 8-hour response time as part of a basic contract service 
level, you might have options available that will allow for 4-hour or 2-hour 
response times. Other options might include 24/7-support coverage or multiple site 
coverage.

1. Open the Contract Options Maintenance window.
Cards > Contract Administration > Contract Options
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2. Enter or select a contract option ID and description.

3. Click Save. 

Set up item extensions

You can assign, modify, or delete additional item information that is not available in 
Inventory Control. For example, certain items might be returnable and other items 
might be metered.

When you set the default vendor warranty codes and seller warranty codes for an 
item, the default codes appear when you create new items in the Equipment 
Maintenance window. 

1. Open the Item Extensions window.
Cards > Service Call Management > Extensions > Item

2. Enter or select an Item Number. 

3. Add additional details for the item. For more information, see Set up item 
extensions in the Service Call Management documentation.

4. Click Save.

Set up customer extensions

You can create, modify, or delete customer information that’s not available in 
Receivables Management. You can type the default time zone, office hours, service 
area, and other information that may be used when servicing the customer account.

You can attach an unlimited number of address codes to the customer record within 
the customer extension file.

The Allow PMs, Annual PM Month and Day, Last Service Date, and Address 
Option fields are not used with Contract Administration. For more information, see 
the Preventive Maintenance and Service Call Management documentation.
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1. Open the Customer Extensions window.
Cards > Service Call Management > Extensions > Customer

2. Enter or select a customer and address. 

3. Select customer information. 

4. Select Allow $0.00 Contract SOP Lines to allow the creation of Sales Order 
Processing line items during the contract billing process even when those line 
items have no currency value. 

5. Click Contacts to type contact information for multiple contacts. You can track 
them for each customer by address ID. 

6. Click Unavailable to type the times when the customer is not available for 
service work to be performed. 

7. Click Save.

Set up warranties

You can define codes that represent the different types of warranties offered to your 
customers. These codes can represent the original manufacturer’s warranty or your 
company’s warranty on equipment maintained, sold by your company, or 
maintained and sold by your company.
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1. Open the Warranty Maintenance window.
Cards > Service Call Management > Warranty

2. Enter warranty details. For more information, see Set up warranties in the 
Service Call Management documentation.

3. Click Save.

Set up equipment maintenance cards

You can create a record for any specifically identifiable equipment within your 
installed database of customers. The maintenance card contains all the information 
for this equipment, including the owner and the location of the equipment and 
warranty information. You can track several dates for each equipment item. 

1. Open the Equipment Maintenance window.
Cards > Service Call Management > Equipment

2. Enter equipment information. For more details, see Set up equipment maintenance 
cards in the Service Call Management documentation.

3. Click Save.
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Part 2: Transaction activity
Use the procedures described in these topics to create templates, quotes, and 
contracts. All the standard contract entry tasks are described in this part of the 
documentation. 

The following topics are discussed:

• Chapter 3, “Routine procedures,” describes how to create and transfer contract 
documents.

• Chapter 4, “Posting procedures,” explains how to generate contract bills, create 
revenue recognition entries in General Ledger, and post meter readings.

• Chapter 5, “Maintenance procedures,” describes processes such as renewing a 
contract or canceling a contract line.

If you need more specific information than is provided in this part of the 
documentation, use the Help, which contains detailed descriptions of each window 
and each data entry field. Checklists describing all the procedures in this part of the 
documentation also are included in the Help. For more information, see the System 
User’s Guide (Help > Printable Manuals).
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Chapter 3: Routine procedures
The Contract Entry/Update window is like an actual contract document, with 
header and line item detail information. You can use it to create quotes, contracts, 
and templates.

Eliminate duplicate entry of similar documents by transferring one type of 
document to another and from one customer to another customer.

This information is divided into the following topics:

• Enter a contract
• Enter a template
• Enter a quote
• Liability types revenue recognition details
• Contract response time details
• Contract information rolldown details
• Transfer a quote, contract, or template to a contract

Enter a contract

Contracts explain the agreements you have with your customers in document form. 
They can contain information about services, time frames, billing, and charges.

Each contract has a unique contract number, which is assigned automatically. 

You can create new contracts by transferring an existing quote or template to a new 
contract or by clicking New. When a quote or template is transferred to a contract, 
details about the document, customer, and items are displayed on the contract 
automatically. For more information, see Transfer a quote, contract, or template to a 
contract on page 30.

When contracts are created from Sales Order Processing, the Source Record Type 
field for the contract shows Sales Order and the Source Contract field shows the 
invoice number.
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1. Open the Contract Entry/Update window.
Transactions > Contract Administration > Contract Entry/Update

2. Select Contract as the record type and click New. 

3. Enter or select a customer ID. Customer information is displayed.

4. Enter or accept the default contract type. For more information, see Set up 
contract types on page 13.

5. To place the contract on hold, select the Hold check box. When a contract is on 
hold, any service calls created for the customer also are placed on hold, and you 
can’t bill or recognize revenue for the contract.

6. To bill the contract in detail, giving each item on the contract one billing line 
item, select the Invoice Detail check box.

7. To set up the contract for self-renewal, select the Evergreen check box. 

8. Enter the contract length and contract period.

9. Enter the contract start date. The contract end date is calculated based on the 
contract length, period, and start date that you have selected.

10. If the customer is billed at the beginning of the billing period, select the Pre 
Paid check box.

11. Select the price book and currency ID.

12. Enter the contract billing length and select the contract billing period. 

13. Enter or accept the default contract billing start date. The default start date is 
based on the contract start date and the prepaid setting. The contract billing end 
date is calculated for you based on the contract billing length, period, and start 
date that you have selected.

14. Enter the bill day, which is the day that an invoice is generated.
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15. Enter the billing frequency, which is how often the contract will be billed.

16. Enter or select a bill-to customer and address if it is different than the contract 
customer and their primary address. This customer ID is sent to Sales Order 
Processing when contract billing is performed.

17. Enter the percentage of the base price for parts, labor, and miscellaneous items 
that the customer is responsible for paying for. 

If the customer is responsible for paying on preventive maintenance service 
calls, type the percentage of the price for parts, labor, and miscellaneous items.

18. Enter or select a service type, which is used on service calls taken against the 
contract. 

19. Enter a signing date, which is the date the customer signed the contract.

20. Enter or select the department that represents the site in posting accounts.

21. Select a liability type, or method of recognizing revenue, from the list. If the 
billing frequency is set to monthly, the liability type does not apply.

22. Select the Smooth Invoices check box to indicate that the same currency 
amount should be used for each credit line invoice record over the total contract 
billing life.

23. Select the Smooth Revenue check box to indicate that the same currency 
amount should be used for each fiscal period revenue record over the total 
contract life.

24. Click Sites to open the Contract Site window, where you can create sites, so you 
can provide contract services to multiple physical locations under a single 
quote.

Click Add All to create a site record for each one of the customer’s address IDs. 

To create individual sites, type or select the address ID. Once the site record has 
been created, you can type different contract start and end dates as long as they 
are still within the contract header start and end dates. 

Select a site and click Options to add or modify coverage options at the site 
level.

Select the appropriate site and click Lines to add line items to the quote. Line 
items shown here are valid for only the particular site that they were created 
under. 

Click OK and return to the Contract Entry/Update window.

25. Click Contract Lines to enter items in the scrolling window for the contract.

Item Number Indicates that all selected contract items must be set up within 
Inventory Control.

Equipment Number Defines the item being placed on the contract.
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U of M Indicates the selling unit of measure selected in the Item Pricing 
Maintenance window.

QTY Indicates the quantity of inventory units. When you type item quantities 
for contracts, inventory quantities won’t be affected and items won’t be 
allocated. When you type a line item with an equipment number attached, the 
QTY field is set to 1 automatically.

Monthly Price Indicates the cost of the line item that comes from the price 
book specified on either the contract header or contract site header. 

Description Changes on only the current document. Descriptions for the line 
items appear automatically from the Inventory Item Maintenance window. 

Config Reference Indicates that the configuration reference is added to the 
contract lines from the list of configurations that have been set up for the 
customer. It is a unique identification representing a customer’s system and 
components. 

Contract Start Indicates that the coverage start date on the line item should 
be equal to or after the contract header and site start date.

Contract End Indicates that the coverage end date on the line item should be 
equal to or before the contract header and site end date.

Bill Start and End Date Indicates when billing begins and ends for the 
specific contract line.

Extended Price Indicates the gross amount for the line item before the 
calculation of any discounts or taxes.

Click OK and return to the Contract Entry/Update window.

26. Click Options to add different coverage options to the contract.

27. Click Periods to make changes to the coverage periods.

28. Click Renewal to set up renewal terms.

29. Click Non-Covered to enter items that will not be covered by the terms of the 
quote. Then, type or select an item number. Any of the displayed item numbers 
that are used on a service call are billed fully to the customer, outside the terms 
of the quote.

30. Click Profitability to compare actual profits and costs to what was estimated.

31. Save, print, or transfer the contract to another quote or a contract. 

Before you transfer a contract, you must select the appropriate transfer options 
for the type of document you are transferring to. Once you complete a transfer, 
the new contract number is displayed in the New Contract field. For more 
information, see Enter a template on page 27 or Enter a quote on page 27.
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Enter a template

A template is a reusable document that contains basic contract details. Contract 
templates are transferred to another document type or deleted. To start a new quote 
or contract, transfer a template to a quote or a contract. The template remains 
available for transferring to new quotes or contracts until you delete it or transfer it 
to history.

Because the actual customer ID is selected when the template is transferred into a 
quote or contract, the customer ID that you select for the template is irrelevant. 

By typing a segment ID for each contract you set up, you can break down expenses 
and revenues accordingly when you print financial reports for this account segment 
in the general ledger.

1. Open the Contract Entry/Update window.
Transactions > Contract Administration > Contract Entry/Update

2. Select Template as the record type and click New. 

3. Enter contract information to include in the template. For more information, see 
Enter a contract on page 23.

4. Save, print, or transfer the template to a quote or a contract.

Enter a quote

Customers often request an estimate, or quote, for the cost of contract services 
before they decide to purchase. Preparing a quote is similar to creating an actual 
contract. Your cost and the price to the customer are calculated automatically, 
enabling you to estimate the profitability of the potential contract.

Contract quotes are not active contracts; they either are transferred to another 
document type or deleted. If the customer decides to enter into the contract based 
on the quoted terms, you can transfer the quote to a contract. If the customer 
decides not to enter into the contract, the quote remains available until you delete it 
or transfer it to history.

1. Open the Contract Entry/Update window.
Transactions > Contract Administration > Contract Entry/Update

2. Select Quote as the record type and click New. 

3. Enter contract information to include in the template. For more information, see 
Enter a contract on page 23.

4. Save, print, or transfer the quote to another quote or a contract. 

5. To apply changes to the quote and review new pricing, click What If, then click 
OK.
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Liability types revenue recognition details

The amount of revenue recognized each month is based on the liability type 
selected. You can select from Straight-Line, Block Time, Retainage, Based on Calls, 
or Metered.

Straight-Line Recognizes the contract line extended amount evenly over the 
length of the contract line. Revenue for straight line contracts is calculated as the 
following equation: Extended Price/Coverage Period.

For example, a 12-month contract with an extended price of $2,400.00 recognizes 
$200 each month ($2,400/12 = $200).

Block Time Used for contracts that allow time periods to be sold for contract 
coverage. When service calls are invoiced for blocked time contracts, the value of 
time decreases by the amount of time consumed to complete the service call. 
Revenue for blocked time contracts is calculated as the following equation: 
(Value of Time / Block Time) x Extended price.

For example, a 12-month contract has an extended price of US$2,400.00 and covers 
20 hours of service. Four service calls have been taken with a total of 9 hours billed 
against the contract line. The amount of revenue that is recognized is $1,080.00 ((9 
hrs / 20 hrs) x $2,400 = $1,080).

Retainage Used for contracts providing coverage for a specified amount of 
money. When service calls are invoiced, the Retainage Billed field is updated with 
the total value of the service calls for that contract line. Revenue for retainage 
contracts is calculated as the following equation: (Retainage Billed / Retainage 
Amount) x Extended price.

For example, a 12-month contract has an extended price of $2,400.00 and provides 
$3,000.00 of service coverage. Four service calls have been taken with a total value 
of $900.00 billed against the contract line. The amount of revenue that is recognized 
is $720.00 (($900 / $3,000) x $2,400 = $720).

Based on Calls Used for contracts that provide coverage for a set number of 
service calls specified for each contract line. When service calls taken against the 
contract line are invoiced, the Actual Calls field is updated with the cumulative 
number of service calls for that contract line. Revenue for based on calls contracts is 
calculated as the following equation: (Actual Calls / Max Calls) x Extended price.

For example, a 12-month contract with an extended price of $2,400.00 allows 10 
service calls. Four service calls have been invoiced against the contract line. The 
amount of revenue that is recognized is $960.00 ((4 calls / 10 calls) x $2,400 = $960).

Metered Used for contracts that provide coverage for a base usage amount for 
metered equipment. When service calls taken against the contract line are invoiced, 
the accumulated meter usage can be posted for revenue recognition. Revenue for 
metered contracts is calculated as the following equation: (Accumulated Usage / 
Base Meters) x Extended price. 

For example, a 12-month contract with an extended price of $2,400.00 allows a base 
meter reading of 40,000. The accumulated usage is 7,890. The amount of revenue 
that is recognized is $473.40 ((7,890 / 40,000) x $2,400 = $473.40).
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Contract response time details

You can display time periods, in hours and minutes, that a response must be 
provided on a service call to fulfill the terms of the contract. For example, 
depending on your service contract, this response time may be fulfilled by a 
telephone call to the customer and not necessarily a site visit. 

The default response time can be set at the contract header and applies to each 
contract line created thereafter. Optionally, if you change the response time on the 
contract header, you can choose to roll down to all existing lines. 

The calculated response date and time that is the result of adding the response time 
on the contract line to the service call entry date is displayed in the Service Call 
Dispatch window. For example, a two-hour response time on a service call created 
on 10/15/2007 at 10:00 would show a response date and time of 10/15/2007 at 
12:00, assuming this date and time is covered on the contract line.

Contract information rolldown details

If you make changes to a contract, the changes can be reflected on the contract lines 
or the sites on the contract, or both. The process of rolling down changes to the 
necessary level are detailed below. A message displays, allowing you to select the 
type of roll-down you want to perform.

Automatic information rolldown
If you make changes to any of the following fields, the information is rolled down 
automatically.

• Billing Length
• Billing Period
• Billing Start Date
• Billing End Date
• Bill Day
• Frequency
• Bill To Customer
• Bill To Address
• Liability Type

Prompted information rolldown based on billing status
If you make changes to the following fields and the billing status meets the criteria, 
you can view the changes to only the contract sites, both contract sites and contract 
lines, or neither.

• Contract Type
• Purchase Order number
• Contract Length
• Contract Period
• Contract Start Date
• Contract End Date
• Contract Price Book
• Contract Currency ID
• Base Parts, Labor, or Miscellaneous percentages
• Preventive Maintenance Parts, Labor, or Miscellaneous percentages
• Service Type
• Department
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Prompted information rolldown regardless of billing 
status
If you make changes to the following fields, you can view the changes to only the 
contract sites, both contract sites and contract lines, or neither.

• Vendor ID
• Salesperson ID

Transfer a quote, contract, or template to a contract

You can transfer all contract line items from an existing document of one type to a 
newly created document of another type. For example, if you routinely create 
contracts based on a quote, you can use this window to transfer all line items from 
the existing quote to a new contract document. This procedure explains how to 
transfer a single document from an existing template, quote, or contract to a new 
contract.

You can select customer and address information when transferring a template to a 
quote, because templates are generic documents. Quotes are designed to be 
provided to a specific customer.

Entering a start date allows you to renew a contract for a new contract term or to 
generate a new quote for the next contract term in preparation for the renewal 
process.

The record type you are transferring limits the transfer options. For example, if you 
select to transfer a quote to another record type, you will not be able to type a new 
start date, as the existing quote’s start date will simply be copied to the new 
document.

After the transfer is complete, the newly created document is displayed in the 
Contract Entry/Update window.

Once you complete a transfer, the old contract number is displayed in the Source 
Contract field. The old contract will refer to the newly created document in the New 
Contract field.

1. Open the Contract Transfer window.
Transactions > Contract Administration > Contract Entry/Update > Transfer 
button

2. Select the new record type.



F I E L D  S E R V I C E  -  C O N T R A C T  A D M I N I S T R A T I O N 31

C H A P T E R  3    R O U T I N E  P R O C E D U R E S

The transfer options are not available for transferring to a history record type. 
Documents are transferred “as is” to history.

3. Select whether to keep the same contract document number when transferring 
to the new record type. 

4. Select whether to keep the same meter reading settings in the new document.

5. If the document you are transferring contains any canceled line items, select an 
option from the Cancel Line Transfer list. 

6. Enter or select the customer information to be used on the new document. 

7. Enter a start date for the new document.

8. Click Transfer.
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Chapter 4: Posting procedures
Contract billing, revenue recognition, and meter posting are three areas within 
Contract Administration where posting actually occurs. When transactions are 
posted, they become permanent information. The appropriate contract information 
and equipment maintenance records are updated, invoices or returns in Sales Order 
Processing are created, and journal entries are generated in General Ledger.

For example, when you create a contract, the information is available within only 
Contract Administration and other Field Service modules. Contract billing updates 
the customer’s accounts receivable accounts and the revenue or deferred revenue 
general ledger accounts for certain contracts after the document is posted in Sales 
Order Processing. The transaction also becomes part of an open fiscal year’s 
permanent records.

For more information about posting and the audit trail created by the posting 
process, see the System User’s Guide (Help > Printable Manuals).

This information is divided into the following topics:

• Bill contracts
• Contract billing tables
• Recognize contract revenue
• Post meter readings
• Create contract renewal letters

Bill contracts

You can use contract billing to create documents in Sales Order Processing. These 
documents can include amounts from contract billing (Sales Order Processing 
invoice) or credits that result from canceling contract line items (Sales Order 
Processing return). The contract billing system creates the correct Sales Order 
Processing document automatically based on the needs of each contract.

Only contracts that are ready to be billed at that time are displayed in the Contract 
Billing window. The next bill date for each contract is compared with the Due Date 
field in the Contract Billing window. Any contract with a next bill date on or before 
the due date appears in the billing window. 

If any contracts are set up for automatic renewal, the Run Auto Renew Routine 
check box is available when you open the Contract Billing window.

You can print a preview report to verify the accuracy of the selected contracts. Only 
information for the contracts that you have selected within the Contract Billing 
window is displayed on the preview report. An audit trail report that lists any 
renewed contracts is printed when billing is complete.
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1. Open the Contract Billing window.
Transactions > Contract Administration > Contract Billing

2. Enter or select a due date. If the contract end date is on or before the due date, 
and if the Auto Renew Contract check box is selected in the Contract Renewal 
window, the contract is self-renewing.

3. To bill meter overages along with the current scheduled contract billings, select 
the Include Meter Overages check box. Any outstanding meter overage 
charges are billed to customers along with the scheduled contract bills.

4. To automatically post the Sales Order Processing batches when billing is 
complete, select the Auto-Post Batch check box.

5. Select whether to run the Auto-Renew Routine when billing is complete. When 
selected, completed contracts are transferred to history to create a renewal 
contract.

6. Select how to filter the list of contracts by contract type, customer number, or 
contract number.

7. To post contract billings for the selected contracts, click Invoice. When 
completed, a Contract Billing Audit Report is generated.

8. To update the customer balance in Receivables Management and to affect the 
general ledger accounts, the invoice and return documents generated in Sales 
Order Processing by the contract billing process must be posted. For more 
information, see the Sales Order Processing documentation.

9. Click OK.

Contract billing tables

The account numbers that are used for contract billing depend on several factors: 
the bill frequency of the contract, the contract type assigned to the contract line, the 
bill-to customer ID, and whether the contract is invoiced in detail or in summary.
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For contracts billed in detail, monthly, without discounts, and with the Create 
Revenue check box cleared on the contract, the following accounts are used during 
SOP posting.

For contracts billed in summary, monthly, without discounts, and with the Create 
Revenue check box cleared on the contract, the following accounts are used during 
SOP posting.

For contracts billed in detail, monthly, and with discount, the following accounts are 
used during SOP posting.

For contracts billed in summary, monthly, and with discount, the following 
accounts are used during SOP posting.

Debit/Credit Type Account

Debit RECV Accounts Receivable from bill to customer, if empty, from 
Posting Accounts setup

Debit COMMEXP Commission expense account from Posting Accounts 
setup

Credit SALES Sales account from Contract Type on the contract line

Credit COMMPAY Commission payable from Posting Accounts setup

Credit TAXES Taxes from Posting Accounts setup

Debit/Credit Type Account

Debit RECV Accounts Receivable from bill to customer, if empty, from 
Posting Accounts setup

Debit COMMEXP Commission expense account from Posting Accounts 
setup

Credit SALES Sales account from Contract Type on the contract line

Credit COMMPAY Commission payable from Posting Accounts setup

Credit TAXES Taxes from Posting Accounts setup

Debit/Credit Type Account

Debit RECV Accounts Receivable from bill to customer, if empty, from 
Posting Accounts setup

Debit COMMEXP Commission expense account from Posting Accounts 
setup

Debit MARK Discount account from Contract Type on the contract line

Credit SALES Sales account from Contract Type on the contract line

Credit COMMPAY Commission payable from Posting Accounts setup

Credit TAXES Taxes from Posting Accounts setup

Debit/Credit Type Account

Debit RECV Accounts Receivable from bill to customer, if empty, from 
Posting Accounts setup

Debit COMMEXP Commission expense account from Posting Accounts 
setup

Debit MARK Discount account from Contract Type on the contract 
header

Credit SALES Sales account from Contract Type on the contract line

Credit COMMPAY Commission payable from Posting Accounts setup

Credit TAXES Taxes from Posting Accounts setup
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For contracts billed in detail, frequency of bi-monthly, quarterly, semi-annual, or 
annual, and with no discount, the following accounts are used during SOP posting.

For contracts billed in summary, frequency of bi-monthly, quarterly, semi-annual, or 
annual, and no discount, the following accounts are used during SOP posting.

For contracts billed in detail, frequency of bi-monthly, quarterly, semi-annual, or 
annual, and with discount, the following accounts are used during SOP posting.

For a contract billed in summary, frequency of bi-monthly, quarterly, semi-annual, 
or annual, and with discount, the following accounts are used during SOP posting.

Debit/Credit Type Account

Debit RECV Accounts Receivable from bill to customer, if empty, from 
Posting Accounts setup

Debit COMMEXP Commission expense account from Posting Accounts setup

Credit SALES Accrual/liability account from contract type on the contract line

Credit COMMPAY Commission payable from Posting Accounts setup

Credit TAXES Taxes from Posting Accounts setup

Debit/Credit Type Account

Debit RECV Accounts Receivable from bill to customer, if empty, from 
Posting Accounts setup

Debit COMMEXP Commission expense account from Posting Accounts setup

Credit SALES Accrual/liability account from contract type on the contract 
header

Credit COMMPAY Commission payable from Posting Accounts setup

Credit TAXES Taxes from Posting Accounts setup

Debit/Credit Type Account

Debit RECV Accounts Receivable from bill to customer, if empty, from 
Posting Accounts setup

Debit COMMEXP Commission expense account from Posting Accounts setup

Debit MARK Discount account from Contract Type on the contract line

Credit SALES Accrual/liability account from contract type on the contract line

Credit COMMPAY Commission payable from Posting Accounts setup

Credit TAXES Taxes from Posting Accounts setup

Debit/Credit Type Account

Debit RECV Accounts Receivable from bill to customer, if empty, from 
Posting Accounts setup

Debit COMMEXP Commission expense account from Posting Accounts setup

Debit MARK Discount account from Contract Type on the contract header

Credit SALES Accrual/liability account from contract type on the contract 
header

Credit COMMPAY Commission payable from Posting Accounts setup

Credit TAXES Taxes from Posting Accounts setup



F I E L D  S E R V I C E  -  C O N T R A C T  A D M I N I S T R A T I O N 37

C H A P T E R  4    P O S T I N G  P R O C E D U R E S

Recognize contract revenue

Revenue recognition, sometimes called liability reduction, is the process of realizing 
revenue as it actually is earned. For example, if a customer pre-pays for a 12-month 
contract, a company may recognize only a portion of that revenue each period as 
the contract service is provided. This practice is in accordance with the Generally 
Accepted Accounting Principle (GAAP) of recognizing revenue during the period 
that the costs of earning that revenue actually are incurred in.

Contract Administration conforms to this GAAP requirement if you use it two 
ways: by posting the potential revenue from a contract into a deferred revenue 
account during contract billing and using revenue recognition each fiscal period to 
recognize the proper portion of that revenue. 

Monthly contracts typically are billed as the costs actually are incurred. Select the 
Create Revenue check box in the Contract Header window to set up revenue 
recognition records to generate for monthly contracts.

Only contracts that are ready to have revenue recognized at that time are displayed 
in the Contract Revenue Recognition window. Several criteria are used to determine 
which contracts should appear in the window. 

• Only contract documents that should recognize revenue are considered. 

• Any contracts that are billed monthly and are not selected to create revenue 
are excluded.

• Any contracts that have all zero currency amount line items are excluded.

• Any contracts that have no revenue set to be recognized during the current 
period are excluded.

• Any contracts with a next recognition date after the specified fiscal period 
and year from appearing are excluded. 

If you print a preview report, only information for the contracts you have selected is 
displayed. This preview report should be saved as part of the revenue recognition 
audit trail, because the posting from the Contract Revenue Recognition window 
generates no actual posting report.

The General Posting Journal is generated when the batch named LIABI (liability) is 
created by Revenue Recognition posting in General Ledger. It is the only posting 
journal that is created during the revenue recognition process.
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1. Open the Contract Revenue Recognition window.
Transactions > Contract Administration > Revenue Recognition

2. Select the fiscal year and period to post revenue recognition for.

3. Select whether to include pre-paid contracts.

4. Select the M box for all the contracts you’re posting revenue recognition for.

5. Click Preview to print a preview report. 

6. Access the LIABI batch in the financial series and print the journal edit list.

7. Post the LIABI batch.

8. Click Post.

9. Repeat this process for revenue recognition each month.

Post meter readings

Meter posting is one method that can be used to post meter readings, sometimes 
called meter “clicks,” against an item. The meter readings that are posted can be 
used as a basis for contract billing, revenue recognition, or both. Meter readings can 
be entered in the Meter Posting window, in the Equipment Maintenance window, 
on a service call, or directly by a customer.

Meter readings can be entered in a batch in the Meter Posting window. All the 
metered items for a particular customer location are visible within the window to 
ensure that meter readings are entered for the correct customer equipment. 

You can enter up to five different meter readings for each piece of equipment. This 
option can be especially important for things such as color copiers, which 
sometimes contain as many as three different meters, one for black and white 
copies, a second for color copies, and a third meter for the total copies used. 

Meters also can be used to track information about an item, such as one meter to 
show the number of total visits to a web site and another meter to track the number 
of hits to the same web site by unique user IDs.
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When you post meter readings, the Equipment Maintenance - Meters window is 
updated for any items with new meter readings. Also, any relevant contract line 
items are updated to reflect the meter usage. Contract billing and revenue 
recognition might be affected by the meter usage, depending on how those 
contracts were set up. Once posting is complete, a Meter Posting Audit report is 
generated, providing a record of the transactions that have been created.

1. Open the Meter Posting window.
Transactions > Contract Administration > Meter Posting

2. Enter or select a batch ID and a short description.

3. Enter or select an entry date.

4. Enter or select a customer ID and address ID. Customer information is 
displayed.

5. Enter an item number and equipment number.

6. Click Preview to print a preview report. 

7. Click Post.

Create contract renewal letters

A sample Microsoft Word template for renewing contracts is supplied with the 
Field Service Series software. You can customize the template to meet your needs. 
The letter can contain information about when the contract will expire, but does not 
affect the contract. The file is placed in the Letters folder during the Field Service 
Series client installation. 

Before using contract renewal letters for the first time, you must create a directory 
called eEntrprs at the root of the Program files. For example, you could place the 
directory as C:\Program Files\eEntrprs. Then copy the Renewal.dot file from the 
Letters folder and paste it into the eEntrprs directory.
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1. Make sure Microsoft Word is not running.

2. Open the Contract Entry/Update window.
Transactions > Contract Administration > Contract Entry/Update

3. Enter or select a contract document.

4. Click Renewal. 

5. Click Letter to open Microsoft Word and merge the data from the contract into a 
document based on the template.
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Chapter 5: Maintenance procedures
It’s important to maintain your contract information to preserve the accuracy of 
your records. 

Throughout the contract process, you can print a variety of reports that you can use 
to double-check the contracts you’ve entered. If you identify errors, you must 
correct them to ensure accurate reporting of your contract activity.

You can delete or cancel contract documents that are no longer valid. You also can 
renew contracts that will continue beyond the contract end date.

You also can move completed contracts to history and remove nonessential history. 

This information is divided into the following topics:

• Correct posted contract invoices
• Reverse posted revenue
• Renew contract documents
• Automatically renew contract documents
• Cancel contract lines and contract documents
• Move or renew contract documents
• Maintain evergreen contracts
• Remove contract history

Correct posted contract invoices

Once a contract invoice has been posted, you can’t make corrections directly to the 
contract because the information has become a permanent part of your contract 
records. If you discover a mistake after an invoice has been generated, you’ll need to 
correct it using one of three methods.

You could modify the unposted Sales Order Processing invoice that was created by 
Contract Billing, which is explained in this procedure. Or, you could cancel the 
contract line that generated the incorrect invoice amount and add a new 
replacement contract line if the Sales Order Processing invoice has already been 
posted. Or, you could enter an invoice or return document manually in Sales Order 
Processing to show the discrepancy. 

The Sales Posting Journal provides a record of changes you’ve made during 
transaction entry. When you close the Sales Transaction Entry window after posting 
documents individually, the Sales Posting Journal is printed for all the documents 
that have been posted.

Audit trail reports are optional, and you can print them when you set up your 
software. For a more information, see “Transactions” in the System User’s Guide 
(Help > Printable Manuals).

Because the document number used in Sales Order Processing for identifying the 
contract invoice is not the same as the contract number, you must find the invoice 
number that needs to be modified. To find the contract, open the Contract Entry/
Update window and select the expansion button next to the contract number to 
open the Contract Header window. Then, click Invoice to open the Contract Invoice 
History window, which displays all the Sales Order Processing invoices generated 
for the contract.
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1. Open the Sales Transaction Entry window.
Transactions > Sales > Sales Transaction Entry

2. Enter the document number used in Sales Order Processing to identify the 
contract invoice. Because it is not the same as the contract number, you may 
need to find the number for the invoice that needs to be modified.

3. Modify the invoice as needed. 

4. To print the document, choose File > Print, then select your printing options.

To print documents individually, be sure you’ve selected the Edit Printed 
Documents option in the individual document setup windows and that a 
password hasn’t been entered for that option. If you don’t select this option or if 
you enter a password, you can print only documents that have been entered in 
a batch.

5. Print an edit list before posting to verify the accuracy of the transactions. (Edit 
lists can be printed for only invoices and returns entered in a batch.) To print an 
edit list, choose File > Print while the document is displayed in the Sales 
Transaction Entry window. Select your printing options. 

6. Click Post.

Reverse posted revenue

There may be times when revenue has been incorrectly recognized or changes are 
required on a posted revenue entry. You can reverse posted contract revenue so that 
the revenue can be recognized later.
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1. Open the Contract Revenue Recognition Reversal window.
Tools > Utilities > Project > Service Utilities > Revenue Reversal

2. Select the proper fiscal year and period. Revenue entries are displayed. 

3. Select all entries to reverse.

4. Click Preview to view the Revenue Recognition Preview report. 

5. Click Post. General Ledger reversing entries are generated and the revenue is 
added back to the selected contracts so that it can be recognized again in the 
future.

Renew contract documents

You can renew contracts by creating a new contract based on an existing contract. 
Instead of re-entering all the information, you can transfer line items from an 
existing contract document of one type to a new contract document of another type. 

This procedure explains how to transfer information from an existing contract to 
either a new quote or contract in order to renew a contract. You can keep the same 
contract document number when transferring to any other record type.

If you select a new price book, it is used to determine the line item pricing for the 
next contract period when the existing contract is transferred to either a quote or a 
new contract.

During the transfer process, new documents are created based on the information 
you entered in the Contract Transfer window. The newly created document is 
displayed in the Contract Entry/Update window and the old contract number is 
displayed in the Source Contract field. 
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1. Open the Contract Renewal window.
Transactions > Contract Administration > Contract Entry/Update > Renewal 
button

2. Select a price book. Click OK to return to the Contract Entry/Update window.

3. Click Transfer, then enter transfer details. See Transfer a quote, contract, or 
template to a contract on page 30 for more information.

4. Click Transfer.

Automatically renew contract documents

Setting up documents for automatic renewal ensures that all invoices and revenue 
recognition have been completed for the contract. It also ensures that the 
information in the renewal window is used to create the new contract. Canceled 
contract lines are not copied over to the new contract. 

You can set up a document for automatic renewal by following the transfer process 
or by renewing the contract using the Contract Move Routine window. For more 
information, see Move or renew contract documents on page 45.

When the last invoice for the contract is billed and the Run Auto-Renew routine 
check box is selected, the contract is renewed automatically based on the 
information in the renewal window. 

You also can use the Auto-Renew routine separately from Contract Billing (Tools > 
Utilities > Project > Service Utilities > Auto Renew Contracts). Enter a due date 
and select an option, then click Process.

1. Open the Contract Renewal window.
Transactions > Contract Administration > Contract Entry/Update > Renewal 
button

2. Select the Auto Renew Contract option.

3. Specify any other renewal options.

4. Click OK.
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Cancel contract lines and contract documents

If you cancel the contract line from its original start date, a credit is generated for the 
entire amount of the contract line that was billed the next time contract billing is run 
for this contract. If the contract line is canceled on a date after the start date but 
within a period that has already been billed to the customer, a credit is generated for 
the prorated time that was canceled within the billed period. If the contract line is 
canceled for any date outside a previously billed period, no credit is generated. 
Instead, the contract line will continue to bill up to the date of cancellation.

If the contract is set to a billing cycle that would recognize revenue separate from 
billing (bi-monthly, quarterly, semi-annually, or annually), all unrecognized revenue 
up to the cancellation date is recognized immediately the next time you run revenue 
recognition for the contract. If the contract is cancelled from a point where revenue 
has been recognized already, a proportional amount of recognized revenue is 
reversed the next time revenue recognition is performed for the selected contract.

1. Open the Contract Maintenance - Lines window.
Transactions > Contract Administration > Contract Entry/Update > Contract 
Lines button

2. Select the line to cancel.

3. Click Cancel Line and enter the date when the selected line should be canceled.

4. Click OK.

Move or renew contract documents

You can streamline renewals by transferring all the contract line items from an 
existing document to a new document. You can transfer a document of one type to a 
new document of another type. You also can transfer completed contract documents 
from open contract tables to the contract history tables. This procedure explains 
how to transfer information from a template, quote, or contract to history, and then 
renew the contract.

There are several reasons that you might transfer a document to history. By 
transferring a contract to history, the contract lookup window will display only 
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active contracts, because the document now will appear as a history document type, 
which is still available if needed. Once a contract has reached the end of its coverage 
period, all billing has been completed, and all outstanding revenue has been 
recognized, you should transfer the contract to history.

If the same contract number is kept, the contract cannot be renewed until the 
original has been moved to history. You may need to retain certain documents if 
your company has a data-retention policy that requires doing so.

You can transfer unused quotes or templates to history to keep a record of the 
document for later use. The lookup windows will contain only the active quotes 
and templates, making it easier to find specific documents.

During the transfer process, a new history document is created and displayed in the 
Contract Entry/Update window.

1. Open the Contract Move Routine window.
Tools > Routines > Contract Administration > Contract Move

2. Select a Record Type. All documents of the selected type with a contract end 
date up to and including the contract end date is displayed.

Contracts transferred from history will be transferred to a quote type.

3. Select range criteria. 

4. Select whether to display records from Open or History contract tables. When 
moving documents to history, select the Open contract tables.

5. To move a document to history, select the History check box next to the 
document to be moved. 

6. To renew a completed contract while moving the completed contract to history, 
select the Renew check box.

7. Click Process.
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Maintain evergreen contracts

You can set up a contract to renew automatically with the terms you specify by 
setting it up as an evergreen contract. The Evergreen check box on the window 
applies to all lines on the contract.

An evergreen contract is active until it reaches the renewal terms that you set up or 
until you manually cancel the contract. You can cancel the contract at any time by 
using the existing cancel buttons. When the next invoice and revenue recognition 
records are created for an evergreen contract, the record is ready for contract billing.

Only the next contract line invoice will be generated when you begin contract 
billing. For monthly contracts without revenue, only an invoice record will be 
generated. For contracts with contract revenue, the invoice record and required 
revenue recognition records will be generated for the next billing cycle if the Create 
Revenue check box is selected on the contract. 

If you enter a cancellation date that leaves invoices or credits unposted, the contract 
status will change to Pending Cancellation until everything is posted. While the 
contract is in Pending Cancellation status, you can change the cancellation date or 
reinstate the contract by using the Evergreen Pending Cancel Option window.

1. Open the Evergreen Contract Review window.
Transactions > Contract Administration > Contract Entry/Update > Renewals

2. Enter the renew limit, which is the number of times the contract will be 
renewed. The Times Renewed field will display the number of times the 
contract has been renewed already. The termination date is set when the 
contract has been billed for all terms.

3. Enter the customer’s name in the Renewal Contact field to update the contact 
name for each renewal term.

4. Enter or select the renew price book.

5. If a new purchase order is required for your customer’s records for each 
renewal term, select the New PO check box.

6. Enter the Max Percentage Increase and the Percentage Carried Forward.

7. Click OK.
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Remove contract history

You can maintain history records for any contract document to keep useful 
information for auditing purposes. If you’re keeping history, records can be kept 
and reviewed for an unlimited number of years. Because historical records increase 
the amount of storage space needed, you should remove history periodically to 
ensure that you’re keeping only the information you need. 

Before removing history, back up your company’s data. For more information, see 
the Maintenance Procedures topic in the System Administrator’s Guide (Help > 
Printable Manuals).

1. Open the Contract Purge Utility window.
Tools > Utilities > Project > Service Utilities > Purge Contracts

2. Select a contract record type (contract or quote) and a specific date that 
contracts should be removed up to. 

3. Click Print to print a Contract History Purge report without removing any 
actual contract history. 

4. Click Remove.
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Part 3: Inquiries and reports
You can store a lot of detailed information about your business’ contract activity. If 
you ever need information about a specific transaction or general information about 
a group of contracts, you can use inquiries and reports.

To view contract profitability or transaction activity, use inquiry windows. The 
inquiry windows provide easy access to detailed or summarized contract 
information.

To analyze contract activity and pinpoint errors in transaction entry, use reports. 

The following topics are discussed:

• Chapter 6, “Inquiries,” explains how to use various inquiry windows within 
Contract Administration to view important information on screen.

• Chapter 7, “Reports,” describes how to use the reports within Contract 
Administration to print needed information in the format you prefer.
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Chapter 6: Inquiries
You can use review current contract transaction and contract analysis information 
by using the SmartList option or by using inquiry windows.

Use SmartList
You can use SmartList to run queries about contract information. Default queries 
are set up automatically, and you can set up customized queries at any time. You 
also can export the results of your queries into Microsoft Word or Excel® 
documents. To use SmartList, choose View > SmartList. For more information, see 
the System User’s Guide.

Use inquiry windows
Inquiry windows provide easy access to information so that you always have a 
current view of contract analysis information. Some inquiry windows have the 
same fields and buttons as the maintenance windows that the original information 
was entered in. 

The contract inquiry windows are informational—you can’t make changes to the 
contract documents you’re viewing. To make changes to any non-billed contracts, 
use the Contract Entry/Update window.

Some inquiry windows have unique information that does not appear on entry 
windows. You can open each of these windows by choosing Inquiry > Contract 
Administration > select a window.

• Contract profitability
• Contracts by customer inquiry
• Contract audit inquiry

Contract profitability

Use the Contract Profitability window to view information about the proactive and 
reactive profitability for a quote, contract, or historical contract.

To view more detailed information about a particular document, select the 
document number. Enter or select a Contract Number to view the document as it 
was originally entered.

To view more detailed information about a particular service call attached to the 
contract document, enter or select a Call Number to view the service call document.

Contracts by customer inquiry

Use the Contracts by Customer Inquiry window to view all detailed contract line 
items entered in Contract Administration for a particular customer. You can further 
limit the number of items displayed in the inquiry by selecting a specific item 
number, equipment number, or both.

To view more detailed information about a particular document, select the 
document number. Enter or select the Contract Number to view the document as it 
was originally entered.
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To view more detailed information about a particular customer, select the customer 
number, then enter or select the Customer ID.

Contract audit inquiry

Use the Contract Audit Inquiry window to view all changes that have occurred 
within a particular contract document. Some of the tracked changes include the 
addition, modification, and cancellation of contract lines, the transfer of contract 
documents, and the change of contract header information.

To view more detailed information about a particular document, select the 
document number. Enter or select the Contract Number to view the document as it 
was originally entered.
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Chapter 7: Reports
Use Contract Administration reports to view the remaining block time or retainage 
on your contracts or to view the actual profitability for your contracts. Use this 
information to help you print reports and select report options.

This information is divided into the following topics:

• Contract Administration report summary
• Reports you can use with named printers
• Specify a Contract Administration report option

For information about creating and printing reports, using sample reports and 
modified reports from the Reports Library, and the reporting tools that you can use 
with Microsoft Dynamics GP, see the System User’s Guide (Help > Printable 
Manuals).

For information about named printers, see the System Administrator’s Guide 
(Help > Printable Manuals).

Contract Administration report summary

You can print several types of reports using Contract Administration. Some reports 
are printed automatically when you complete certain procedures. For example, 
audit trail reports are printed automatically when you generate contract bills. You 
can print some reports during procedures. For example, you can print a Contract 
Pricing List while entering contract pricing in the Contract Pricing Maintenance 
window.

The following table shows the report types available in Contract Administration 
and the reports included in those categories.

Reports you can use with named printers

You can assign printers to the following documents and reports:

• Posting journals and preview reports
• Analysis reports
• Contract cards and printouts
• Sales Order Processing contract reports

Report type Report Printing method

Setup reports Contract Type List
Option List
Price Book Code List
Contract Pricing List

Open File > Print in the setup windows 
or click the Printer icon.

Audit reports Contract Billing Audit Trail
Revenue Recognition Audit Report

Printed automatically when you close 
the Contract Billing window or the 
Contract Revenue Recognition window.

Analysis reports Contract Expire
Block Time
Meter Cards
Contract Retainage
Contract Revenue

Create report options in the Preventive 
Maintenance Reports windows.
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Specify a Contract Administration report option

Report options include specifications for sorting options and range restrictions for a 
particular report. To print Contract Administration reports, you must first create 
report options. You can set up each report with different options. 

A single report option can’t be used by multiple reports. You must create identical report 
options separately.

1. Open a Contract Administration reports window.
Reports > Contract Administration > Contract Expire

2. Select a report.

3. Click New.

4. Enter a name and definition for the option. The name you choose for the option 
won’t appear on the report. The selections available for defining report options 
vary, depending on the report type you’ve selected.

You can enter only one restriction for each restriction type. For instance, you can insert 
one serial number restriction and one customer ID restriction.

5. Enter range restrictions.The available ranges vary, depending on the report type 
you’ve selected.

6. Insert or remove the ranges for the Restrictions List.

7. Click Destination to select a printing destination. Select Ask Each Time to 
select printing options each time you print this report option.

8. Click Print.
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contract history

purging 48
removing 48

contract information rolldown details, 
explaining 29

contract invoices
correcting 41
correcting after posting 41

contract lines, canceling 45
Contract Maintenance - Lines window, 

displaying 45
Contract Move Routine window, 

displaying 46
contract options

setting up 17
setting up service coverage 17

Contract Options Maintenance window, 
displaying 17

contract price books, setting up 11
Contract Pricing Maintenance window, 

displaying 12
Contract Purge Utility window, 

displaying 48
contract quotes

creating 27
deleting 27
printing 27
viewing 27

contract renewal letters, creating 39
Contract Renewal window, displaying 44
contract response time, explaining 29
Contract Revenue Recognition Reversal 

window, displaying 43
Contract Revenue Recognition window, 

displaying 38
contract templates

creating 27
deleting 27
printing 27
viewing 27

Contract Transfer window, displaying 30
Contract Type Maintenance window, 

displaying 14
contract types

customizing 13
setting up 13

contracts
billing 33
canceling 45
creating 23
moving 45
renewing 43
setting up to renew automatically 44
transferring 45
transferring to a contract 30
using in Contract Administration 10

corrections
correcting posted contract invoices 41
printing posted contract invoices 41

coverage options, setting up for contracts 
17

credits, generating from cancellations 45
customer class pricing, setting up for 

contracts 11
customer extensions, setting up 18
Customer Extensions window, displaying 

19
customer number pricing, setting up for 

contracts 11

D
default entries in Contract 

Administration, setup 15
deferred revenue account, posting into 

from a contract 37
document security, setting up for 

contracts 17

document security options, setting up in 
Contract Administration 15

document types, using in Contract 
Administration 10

documentation, symbols and conventions 
2

E
equipment maintenance cards, setting up 

20
Equipment Maintenance window, 

displaying 20
estimates

setting up in Contract Administration 
27

transferring to a contract 30
Evergreen Contract Review window, 

displaying 47
evergreen contracts

changing status 47
creating 23
maintaining 47

extensions
setting up customer extensions 18
setting up for items 18

G
General Posting Journal, generating from 

revenue recognition 37

H
help, displaying 3
Help menu, described 3
hierarchy, for pricing 11
history, removing contracts 48

I
icons, used in manual 2
item class pricing, setting up for contracts 

11
item extensions, setting up 18
Item Extensions window, displaying 18
item number pricing, setting up for 

contracts 11

L
lessons, accessing 4
liability reduction, processing 37
liability types 28
lookup window, displaying 3

M
maintenance cards

setting up 20
setting up for equipment 20

manufacturers’ warranties, setting up 19
meter posting, posting readings 38
Meter Posting Audit report, generating 38
Meter Posting window, displaying 39
meter readings, posting 38
metered type, explaining liability types 28
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N
navigation, symbols used for 2
new features, information about 4

O
office hours, setting up default 

information for customers 18
Option Security - Contract Administration 

window, displaying 17
options, setting up contract options 17
Orientation training, accessing 4

P
passwords, setting up in Contract 

Administration 17
posted contract invoices, correcting 41
posted revenue, reversing 42
posting journals, generating from revenue 

recognition 37
potential revenue, posting from a contract 

37
price books, setting up for contracts 11
pricing, setting up in Contract 

Administration 11
print, reports in Contract Administration 

53
prompted information rolldowns

based on billing status 29
regardless of billing status 29

Q
quote, transferring to a contract 30
quotes

creating in Contract Administration 
27

moving 45
renewing 45
transferring 45
using in Contract Administration 10

R
readings, posting meter readings 38
renewal contracts

creating 43
keeping the same contract number 43

renewal letters, creating for contracts 39
reports in Contract Administration 53

Block Time 53
Contract Billing Audit Trail 53
Contract Expire 53
Contract Pricing List 53
Contract Retainage 53
Contract Revenue 53
Contract Type List 53
creating options 54
Meter Cards 53
Option List 53
Price Book Code List 53
report types 53
specifying printing options 54
specifying range restrictions 54
specifying sorting options 54

reports in Contract Administration 53 
(continued)

using with Named Printers 53
required fields, described 3
resources, documentation 3
response time, explaining for contracts 29
retainage type, explaining liability types 

28
revenue

realizing 37
recognizing 37
reversing posted revenue 42
undoing posted revenue 42

revenue recognition, processing 37
rolldown details, explaining for contracts 

29

S
Sales Order Processing document, 

creating from contract billing 33
Sales Transaction Entry window, 

displaying 42
schedules, setting up for pricing 11
security, setting up for contract 

documents 17
service areas, setting up default 

information for customers 18
Service Setup - Contracts window, 

displaying 16
Setup Checklist

using for Contract Administration 10
using for Preventive Maintenance 10

setup in Contract Administration 9
before you begin 10
using the Setup Checklist 10

setup in Preventive Maintenance 10
setup procedures

setting up Contract Administration 9
setting up Preventive Maintenance 9

sheets, for pricing 11
straight-line type, explaining liability 

types 28
symbols, used in manual 2

T
templates

creating in Contract Administration 
27

moving 45
renewing 45
transferring 45
transferring to a contract 30
using in Contract Administration 10

time zones, setting up default information 
for customers 18

tutorial, accessing 4
types

contract 13
liability 28

U
up-charges, setting up contract pricing 11

upgrade information, accessing on the 
Web 4

W
warranties, setting up 19
Warranty Maintenance window, 

displaying 20
what’s new, accessing 4
workflow, understanding Contract 

Administration 9
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