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Introduction
When integrated with Service Call Management, you can use Preventive 
Maintenance to generate service calls for preventive maintenance work 
automatically, with a minimum of user intervention. 

You also can use Preventive Maintenance to complete the following tasks:

• Create a list of preventive maintenance requirements, called a Preventive 
Maintenance Edit List.

• Generate preventive maintenance service calls.
• Track preventive maintenance history on generated, cancelled, and completed 

preventive maintenance requirements.

This introduction is divided into the following sections:

• What’s in this manual
• Symbols and conventions
• Resources available from the Help menu
• Send us your documentation comments

What’s in this manual

This manual is designed to give you an understanding of how to use the features of 
Preventive Maintenance, and how it integrates with the Microsoft Dynamics™ GP 
system.

To make best use of Preventive Maintenance, you should be familiar with 
systemwide features described in the System User’s Guide, the System Setup 
Guide, and the System Administrator’s Guide.

Some features described in the documentation are optional and can be purchased 
through your Microsoft Dynamics GP partner.

To view information about the release of Microsoft Dynamics GP that you’re using 
and which modules or features you are registered to use, choose Help > About 
Microsoft Dynamics GP.

The manual is divided into the following parts:

• Part 1, Preventive Maintenance setup introduces Preventive Maintenance and 
explains its setup.

• Part 2, Transactions and reports explains how to enter edit lists so that you can 
generate service calls automatically and also explains how to use reports to 
analyze your field service information.
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I N T R O D U C T I O N

Symbols and conventions

For definitions of unfamiliar terms, see the glossary in the manual or refer to the 
glossary in Help.

This manual uses the following conventions to refer to sections, navigation, and 
other information.

Resources available from the Help menu

The Microsoft Dynamics GP Help menu gives you access to user assistance 
resources on your computer, as well as on the Web.

Contents
Opens the Help file for the active Microsoft Dynamics GP component, and displays 
the main “contents” topic. To browse a more detailed table of contents, click the 
Contents tab above the Help navigation pane. Items in the contents topic and tab 
are arranged by module. If the contents for the active component includes an 
“Additional Help files” topic, click the links to view separate Help files that 
describe additional components.

To find information in Help by using the index or full-text search, click the 
appropriate tab above the navigation pane, and type the keyword to find.

To save the link to a topic in the Help, select a topic and then select the Favorites 
tab. Click Add.

Index
Opens the Help file for the active Microsoft Dynamics GP component, with the 
Index tab active. To find information about a window that’s not currently 
displayed, type the name of the window, and click Display.

About this window
Displays overview information about the current window. To view related topics 
and descriptions of the fields, buttons, and menus for the window, choose the 
appropriate link in the topic. You also can press F1 to display Help about the current 
window.

Symbol Description

The light bulb symbol indicates helpful tips, shortcuts, and suggestions.

The warning symbol indicates situations you should be especially aware 
of when completing tasks.

Convention Description

Creating a batch Italicized type indicates the name of a section or procedure.

File > Print The(>) symbol indicates a sequence of actions, such as selecting items 
from a menu or a toolbar or pressing buttons in a window. This example 
directs you to go to the File menu and select Print.

TAB or ENTER Small capital letters indicate a key or a key sequence.
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Lookup
Opens a lookup window, if a window that you are viewing has a lookup window. 
For example, if the Checkbook Maintenance window is open, you can choose this 
item to open the Checkbooks lookup window.

Show Required Fields
Highlights fields that are required to have entries. Required fields must contain 
information before you can save the record and close the window. To change the 
way required fields are highlighted, choose Tools > Setup > User Preferences > 
Display, and specify a different color and type style.

Printable Manuals
Displays a list of manuals in Adobe Acrobat .pdf format, which you can print or 
view.

Orientation Training
Accesses online tutorials that show you how to complete basic procedures within 
Microsoft Dynamics GP. Additional tutorials are available through the 
CustomerSource Web site.

What’s New
Provides information about enhancements that were added to Microsoft Dynamics 
GP since the last major release.

Microsoft Dynamics GP Online
Opens a Web page that provides links to a variety of Web-based user assistance 
resources. Access to some items requires registration for a paid support plan.

Current implementation and upgrade information The most recent 
revisions of upgrade and implementation documentation, plus documentation 
for service packs and payroll tax updates.

User documentation and resources The most recent user guides, how-
to articles, and white papers for users.

Developer documentation and resources The most recent 
documentation and updated information for developers.

Product support information Information about the Microsoft Dynamics 
GP product support plans and options that are available, along with 
information about peer support and self-support resources.

Services information Information about Microsoft Dynamics GP support, 
training, and consulting services.

Microsoft Dynamics GP Community Access to newsgroups, where you 
can ask questions or share your expertise with other Microsoft Dynamics GP 
users.

CustomerSource home page A wide range of resources available to 
customers who are registered for a paid support plan. Includes access to 
Knowledge Base articles, software downloads, self-support, and much more.
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I N T R O D U C T I O N

U.S. Payroll Updates
Provides access to tax updates for state and federal tax withholding. When you 
select an option, the process to install the updates will begin immediately.

Check with your system administrator before installing tax updates. To be sure that tax 
updates are installed correctly, refer to documentation for specific tax updates on the 
CustomerSource Web site.

Customer Feedback Options
Provides information about how you can join the Customer Experience 
Improvement Program to improve the quality, reliability, and performance of 
Microsoft® software and services.

Send us your documentation comments

We welcome comments regarding the usefulness of the Microsoft Dynamics GP 
documentation. If you have specific suggestions or find any errors in this manual, 
send your comments by e-mail to the following address: bizdoc@microsoft.com.

To send comments about specific topics from within Help, click the Documentation 
Feedback link, which is located at the bottom of each Help topic.

Note: By offering any suggestions to Microsoft, you give Microsoft full permission to use 
them freely.

mailto:bizdoc@microsoft.com
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Part 1: Preventive Maintenance 
setup
This part of the documentation contains procedures and information for setting up 
and customizing Preventive Maintenance for your business. Setup procedures 
generally need to be completed only once, but you may refer to this part of the 
documentation at other times to modify or view existing entries. 

The following topics are discussed:

• Chapter 1, “Setup overview,” introduces Preventive Maintenance and explains 
important preparatory information.

• Chapter 2, “Setup in Preventive Maintenance,” explains in more detail how to 
set up events and schedules within Preventive Maintenance.
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Chapter 1: Setup overview
The setup procedures are organized in an order that ensures proper setup.

This information is divided into the following topics:

• Before setting up Preventive Maintenance
• Use the Setup Checklist

Before setting up Preventive Maintenance

Before setting up Preventive Maintenance, complete the setup procedures for 
Service Call Management, including the following tasks:

• Enter Service Call Management settings.

• Create service types, technicians, and offices.

• Enter problem codes, cause codes, and repair codes.

• Set up item extensions, item site extensions, and customer extensions.

• Set up inventory posting accounts in the Posting Accounts Setup window.

You must complete the setup procedures for your company, currency, accounts, and 
posting options. You also should set up tax schedules and tax details. For more 
information, see the System Setup documentation.

If you’re using Preventive Maintenance with Multicurrency Management, be sure 
you’ve also set up currencies, exchange rate tables, and Multicurrency default 
entries. For more information, see the Multicurrency Management documentation.

Use the Setup Checklist

When setting up Preventive Maintenance, either open each setup window and enter 
information, or use the Setup Checklist window (Tools > Setup > Setup Checklist) 
as a guide. See the System Setup Guide (Help > Printable Manuals) for more 
information.
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Chapter 2: Setup in Preventive Maintenance
You can set up your Preventive Maintenance default preferences, such as individual 
preventive maintenance events and preventive maintenance schedules.

When you set up Preventive Maintenance, you can open each window and enter 
information or you can follow the Setup Checklist, which you can use as a guide to 
the setup process. See Use the Setup Checklist on page 9.

This information is divided into the following topics:

• Set up preventive maintenance default entries
• Set up preventive maintenance events
• Set up preventive maintenance schedules
• Assign preventive maintenance schedules to items
• Update customer and item extensions
• Calculate Preventive Maintenance schedules

Set up preventive maintenance default entries

You can set up default entries that affect the preventive maintenance requirements 
you enter. To accelerate the entry process, specify common entries that will appear 
automatically when you enter preventive maintenance requirements. For more 
information, see Set up preventive maintenance events on page 12 and Set up preventive 
maintenance schedules on page 12. 

You also can set up document security options. To prevent users from deleting 
certain documents, while still allowing them to access the window to view or 
update documents, set passwords. If you set up a password, users are required to 
enter the password before deleting the select document type. If an option is 
selected, but a password hasn’t been set up, anyone who has access to the window 
is able to delete the applicable document type.

1. Open the Service Setup-PM window.
Tools > Setup > Project > Service Setup > PM button

2. Enter the number of days to be added to the user date in the Check Days field. 
This number determines the time period to check for preventive maintenance 
requirements in the Preventive Maintenance Generation routine.

3. Click Options to select document security settings. 

4. To allow users to delete or cancel certain document types, select Allow. To 
remove the right for users to delete certain document types, clear the option.

5. To set up passwords, enter a password for each document type.

6. Click OK.
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Set up preventive maintenance events

You can set up the preventive maintenance events that you provide for your 
customers. You also can define default parts, labor, and additional charges that 
might be used on those events. When you set up an event, it is scheduled for one 
occurrence. To create a maintenance schedule, combine events.

1. Open the P.M. Event Maintenance window.
Cards > Preventive Maintenance > P.M. Events

2. Enter or select a code to represent an event. 

3. Enter line type items that will appear on service requests that are created from 
this event. 

When you select each line type, the lower portion of the window will change to 
display the items entered for this event.

4. Click Save.

Set up preventive maintenance schedules

You can set up maintenance schedules by combining the events that might be used 
for a single item. The schedule also defines how often an event occurs.

You can assign one of the two Preventive Maintenance types, floating or fixed, to 
each event on a schedule. 

Fixed The next preventive maintenance requirement is generated based the actual 
completion date of the previous occurrence of that event.

Floating The next preventive maintenance requirement is generated based on the 
date the previous occurrence of that particular event should have been generated.

For example, assume that an event was set up to occur every 6 months, should have 
been completed on January 1, but actually was completed on January 12. If the 
event was floating, the next occurrence would be July 12. If the event was fixed, the 
next occurrence would be July 1.
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C H A P T E R  2    S E T U P  I N  P R E V E N T I V E  M A I N T E N A N C E

The PM Type field works with the Type, Value, and Frequency fields to determine 
when, and how often, a preventive maintenance requirement is generated for an 
event.

A frequency of At indicates that the event will occur only one time in the life of the 
schedule. A frequency of Every indicates that the event is recurring throughout the 
life of the schedule, based on the Type and Value fields.

The Value field indicates the amount of time that must pass or the actual usage that 
must occur before the preventive maintenance requirement is generated.

The Type list represents the basis the kind of preventive maintenance requirement 
is generated. You can select periods of time or meters so that requirements can be 
created based on actual usage, such as mileage.

1. Open the P.M. Schedule Maintenance window.
Cards > Preventive Maintenance > P.M. Schedule

2. Enter or select a code to represent the schedule being created.

3. Enter or select a default service type for this schedule. Any service calls 
generated for the schedule will use this service type.

4. Enter or select the preventive maintenance events that make up the schedule. 

5. Select a PM Type, Frequency, Value, and Type. 

6. Print the schedule, then click Save.

Assign preventive maintenance schedules to items

You can assign a default preventive maintenance schedule to an inventoried item. 
Then, you can assign the default preventive maintenance schedule for the item to an 
equipment record, using the Default button in the Equipment PM Schedule 
window. When you create new equipment records, corresponding preventive 
maintenance schedules will be created automatically. 
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1. Open the P.M. Item Schedule Maintenance window.
Cards > Preventive Maintenance > P.M. Item Schedule

2. Select an item from the inventory.

3. Select a schedule that is assigned to the selected item as the default Preventive 
Maintenance Schedule.

4. Select the Active option to indicate that the assigned schedule should be used 
with the assigned item.

5. Click OK.

Update customer and item extensions

The customer extension and item extension windows contain information that is 
used specifically for the Field Service Series. This information must be entered for 
preventive maintenance requirements to be created successfully.

To update customer extensions:
1. Open the Customer Extensions window.

Cards > Service Call Management > Extensions > Customer

2. Select a Customer ID and an Address ID. Change any information if necessary.
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C H A P T E R  2    S E T U P  I N  P R E V E N T I V E  M A I N T E N A N C E

3. Select the Allow PMs check box. If the customer record is not selected to allow 
preventive maintenance to be performed, no preventive maintenance 
requirements are created for this customer.

4. Select the month that the customer prefers to receive annual preventive 
maintenance service calls from the Annual PM Month list. 

5. Enter the day that the customer prefers to receive monthly preventive 
maintenance service calls in the PM Day field. 

6. Click Save.

To update item extensions:
1. Open the Item Extensions window.

Cards > Service Call Management > Extensions > Item

2. Select an item number.

3. Select the Allow PMs option. If the item record is not selected to allow 
preventive maintenance to be performed, no preventive maintenance 
requirements are created for the item.

4. Click Save.

Calculate Preventive Maintenance schedules

Preventive maintenance events can have a frequency value and type. For example, 
when you set up a preventive maintenance event, the install date from the serial 
master record is used if the PM Month and PM Day fields are blank. Otherwise the 
PM Month and PM Day are used to calculate the PM Date.
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For subsequent preventive maintenance events, Floating PM Types use the 
completion date and Fixed PM Types use the PM Date from the Serial PM History 
record.

X = First preventive maintenance event is based on the PM Month and PM Day 
fields (if populated) or Install Date from the Serial Master record.

Y = The preventive maintenance service call completion date.

Z = The preventive maintenance date for the next preventive maintenance event.

Preventive maintenance events with a type of “At” create only a single preventive 
maintenance event. No subsequent Preventive maintenance events are generated 
for this type of preventive maintenance event.

For the first preventive maintenance event (no Equipment PM History record), if 
the PM Month and PM Day fields are blank, the install date is used as the “base 
date.” If the PM Month and PM Day are populated, the “base date” is set to the PM 
Month, PM Day, and the year from the install date. 

A preventive maintenance event is due when the “base date” plus the event 
frequency is between the “User Date” and the “Check Date.” This guarantees that a 
preventive maintenance service call will not be generated for a previous date even if 
the Install Date is used and it is set to an old date, such as 2001. 

The process of generating a preventive maintenance program will bump the date 
accordingly until the next preventive maintenance event due is current based on 
“User Date” and “Check Date.” All of the following examples are for first 
preventive maintenance events (no Equipment Preventive Maintenance History 
records exist).

Example 1:

• User Date - 3/5/07
• Check Date - 4/30/07
• PM Month - blank
• PM Day - blank
• Install Date - 1/1/01
• Event frequency - 3 months

A preventive maintenance event would be generated for 4/1/07.
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Example 2:

• User Date - 3/5/07
• Check Date - 3/31/07
• PM Month - blank
• PM Day - blank
• Install Date - 1/1/01
• Event frequency - 3 months

No preventive maintenance event would be generated because the next preventive 
maintenance event is not due until 4/1/07 and that date is greater than 3/31/07.

Example 3:

• User Date - 4/5/07
• Check Date - 4/31/07
• PM Month - blank
• PM Day - blank
• Install Date - 1/1/01
• Event frequency - 3 months

No preventive maintenance event would be generated because the next preventive 
maintenance event is not due until 7/1/07 and that date is greater than 4/31/07. A 
preventive maintenance event should have been performed on 4/1/07, but because 
the user date is 4/5/07, no preventive maintenance event would be generated.

Example 4:

• User Date - 5/2/07
• Check Date - 5/31/07
• PM Month - 2
• PM Day - 3
• Install Date - 1/1/01
• Event frequency - 3 months

A preventive maintenance event would be generated for 5/3/07 because the PM 
Month field is not blank and 2 (February) and the PM Day field is not blank and 3.

For all subsequent PMs, the most recent PM Serial History record will continue to 
be used for the specific event to retrieve the base dates. The PM Date (field with this 
name on the Equipment Entry - PMs window accessed from the PM History button 
on the Equipment Maintenance window) is accessible by users so that they can 
change the date for load balancing of Fixed type preventive maintenance events. 

For fixed events, the PM Date (the ETA date of the last preventive maintenance 
service call for that event) is used to determine the next preventive maintenance 
event (after the 1st). For floating events, the Call Date (the completion date of the 
last preventive maintenance service call for that event) is used to determine the next 
preventive maintenance event (after the 1st).
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Part 2: Transactions and reports
Use the procedures described in these topics to create edit lists and generate service 
calls within Preventive Maintenance. 

Detailed information about your field service operations and activities is stored 
within Preventive Maintenance. There may be times when you need information 
about a specific transaction or general information about a group of service calls. 

Use these reports to analyze preventive maintenance activity and pinpoint any 
errors. You can print reports using the Preventive Maintenance Reports menu.

The following topics are discussed:

• Chapter 3, “Edit lists and service calls,” explains how to create and print the 
Preventive Maintenance Edit List and how to generate Preventive Maintenance 
service calls from that edit list.

• Chapter 4, “Reports,” explains how to use reports to analyze your preventive 
maintenance activities.
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Chapter 3: Edit lists and service calls
You can generate edit lists and service calls. You also can select specific preventive 
maintenance requirements within the Preventive Maintenance Edit List and 
generate service calls from those requirements.

This information is divided into the following topics:

• Generate a Preventive Maintenance Edit List
• Generate Preventive Maintenance service calls

Generate a Preventive Maintenance Edit List

You can print a Preventive Maintenance Edit List for items that are used by your 
company or by customers, and that are allowed to generate preventive maintenance 
service calls. The Preventive Maintenance Edit List is a report that contains 
reminders that a particular item is ready to be maintained, based on the passage of 
time or usage described in the item’s Preventive Maintenance Schedule.

The default Generate Up To date is calculated by adding the Check Days from 
Preventive Maintenance Setup to the current user date. Only the requirements that 
should be created between the user date and the Generate Up To date are added to 
the Preventive Maintenance Edit List.

Use the Generate PM Edit List routine to generate the Preventive Maintenance Edit 
List.

1. Open the Generate PM Edit List window.
Tools > Routines > Preventive Maintenance > P.M. Generation

2. Enter or select the restriction criteria that appear on the Preventive Maintenance 
Edit List based on any combination of item number, preventive maintenance 
schedule, customer number, or equipment number.

3. Enter or accept the default Generate Up To date. 

4. Click Generate.

Generate Preventive Maintenance service calls

The Preventive Maintenance Edit List shows all preventive maintenance 
requirements that are ready to be turned into service calls, based on the parameters 
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established on the Preventive Maintenance Schedules for the items. For more 
information, see the Service Call Management documentation.

1. Open the P.M. Edit List window.
Transactions > Preventive Maintenance > P.M. Edit List

2. If any preventive maintenance events should be skipped, select them for 
deletion. 

Select the M (marked to transfer) check box on each event and click Delete to 
remove them from the window.

3. If any preventive maintenance events never should be transferred to a service 
call, select them for cancellation. 

Select the M (marked to transfer) check box on each requirement and click 
Cancel so they will not show up on future edit lists until the next scheduled 
occurrence for each event.

4. Select the preventive maintenance events to transfer to open preventive 
maintenance service calls. 

Select the M (marked to transfer) check box on each event or click Mark All to 
transfer all the selected requirements.

5. Click Generate to process all marked preventive maintenance events and 
generate preventive maintenance service calls.

6. Close this window to print the PM Edit Audit Trail report, which shows the 
preventive maintenance service calls generated for each piece of equipment.
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Chapter 4: Reports
Use Preventive Maintenance reports to view the preventive maintenance schedules 
assigned to your items in inventory or to view the preventive maintenance 
requirements that are ready to be transferred to a preventive maintenance service 
call. Use this information to help you print reports and select report options.

This information is divided into the following topics:

• Preventive Maintenance report summary
• Reports you can use with named printers
• Specify a Preventive Maintenance report option

For information about creating and printing reports, using sample reports and 
modified reports from the Reports Library, and the reporting tools that you can use 
with Microsoft Dynamics GP, see the System User’s Guide (Help > Printable 
Manuals).

For information about named printers, see the System Administrator’s Guide 
(Help  > Contents > System administration).

Preventive Maintenance report summary

You can print several types of reports within Preventive Maintenance. Some reports 
are printed automatically when you complete certain procedures. For example, 
audit trail reports are printed automatically when you generate preventive 
maintenance service calls. You also can print some reports during procedures. For 
example, you can print a Preventive Maintenance Event List while entering 
Preventive Maintenance events in the P.M. Event Maintenance window.

The following table shows the report types available in Preventive Maintenance and 
the reports included in those categories.

Reports you can use with named printers

You can assign printers to the following documents and reports:

• Posting journals 
• Analysis reports 
• Preventive Maintenance cards

Specify a Preventive Maintenance report option

Report options include specifications for sorting options and range restrictions for a 
particular report. To print Preventive Maintenance reports, you must first create 
report options. You can set up each report with different options. 

Report type Report Printing method

Setup reports PM Event Code List
PM Schedule List
PM Item Schedule List

Choose File > Print in the setup windows 
or click the Printer icon.

Audit reports PM Edit Audit Trail Printed automatically when you close the 
PM Edit List window.

Analysis reports PM Listing
PM Due

Create report options in the Preventive 
Maintenance Reports windows.
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A single report option can’t be used by multiple reports. You must create identical report 
options separately.

1. Open one of the Preventive Maintenance report windows.
Reports > Preventive Maintenance > PM Listing

2. Select a report.

3. Click New.

4. Enter a name and definition for the option. The name you choose for the option 
won’t appear on the report. The selections available for defining report options 
vary, depending on the report type you’ve selected.

You can enter only one restriction for each restriction type. For instance, you can insert 
one serial number restriction and one customer ID restriction.

5. Enter range restrictions.The available ranges vary, depending on the report type 
you’ve selected.

6. Insert or remove the ranges for the Restrictions List.

7. Click Destination to select a printing destination. Select Ask Each Time to 
select printing options each time you print this report option.

8. Click Print.
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